Requirements

From CARMA
Revision as of 09:31, 28 May 2008 by Teuben (Talk | contribs)

Jump to: navigation, search

If you want to install Miriad on your laptop, this is what we will likely support:

  • linux (centos, fedora, suse, ubuntu etc.) on IA32 or IA64
  • Powerbook Mac (PPC laptop) - 10.4
  • MacBook (Intel laptop) - 10.4 and possibly 10.5

Although reports on some success under cygwin have been reported, we will not have the resources to fix any Windows related problems if you plan to use cygwin (which is known to have very slow I/O performance). So please prepare to bring Linux or MacOSX. Dual boot machines are fine of course too!

You will need to have pre-installed on your laptop:

  • a C and Fortran compiler (gcc, g77 preferably, though gfortran or even g95 are known to work). If not for development, possibly for shared libraries.
  • X11 and X11SDK (or the relevant -devel packages in linux, on Mac they're installed via Xcode)
  • optionally some development tools, like cvs
  • optionally tools like ds9, xpa tools (needed for ds9) and/or karma

Please send Peter the output of the following commands:

 which gcc
 gcc -v
 which g77          (and/or gfortran, or g95, or f77, at least one should exist)
 g77 -v
 uname -a
 ls /usr/include/X11
 which cvs
 automake --version

Although g77 is the preferred fortran compiler (pgplot ideally needs some VAX dialects), very recent versions of gfortran (e.g. 4.2.2) can also handle these.

Requirements

The above items are the most common ones that a unix machine may miss for development. If you use a Linux based machine, you will need a number of development tools and libraries. Obivously the compiler, tools like gmake, the header files for libraries like X11, and soon the autoconf tools.

things to bring to OVRO

Since OVRO is on a pretty slow internet link, bring ANYTHING you can in terms of potentially finishing the installation of your laptop for CARMA data reduction. This includes the data from the Illinois data archive, as well as linux install CDs, or Mac install DVDs (Xcode is the keyword here!) etc. A list of things we've encountered as people could forget are:

  • mac users should bring their install DVD, Xcode etc.
  • linux users should bring their install DVD(s)
  • we need to prepackage binaries for compilers where needed (e.g. hpc stuff for Mac users), binary releases for Miriad and the optional tools (ds9, karma, ....) that we might want to use.
  • mac users should have the fortran (and C) compiler. I've had good luck with the HPC project compilers for Fortran. Be sure to mate g77 with gcc3 and gfortran with gcc4. Another method can be to install your own g77 compiler, see [[1]]. There is a new project Xcode/gFortran Plugin which I have not tried out.
Personal tools